Hibernating Rhinos

Zero friction databases

Feedback is required: Can we require you to have .NET 4.5 in order to use the profiler UI?

As we want to use the async keyword in the profiler’s client, we think to start targeting the .NET Framework 4.5.

Considering that .NET Framework 4.5 came out a year ago and it is distributed on Windows 8, we think it is acceptable to ask our users to have the .NET Framework installed on the machine.

Users that still need to use the profiler on a machine with just .NET 4.0 would have to use the recent build of the profiler, which is 2197. But since that this build requires this update for the .NET Framework 4.0, we figure out that it is better to require the .NET Framework 4.5 (in order to avoid with strange error for users that do not have this update) or drop the use of the async keyword, which we hope to avoid.

Please let us know your opinion about this change. We will wait two weeks or so in order to get a feedback from you guys, before pushing a new version to production with this change.

Tags:

Posted By: Fitzchak Yitzchaki

Published at

Originally posted at

Comments

Jim Geurts
08/14/2013 02:11 PM by
Jim Geurts

I think that's fine, as you provide a version of the profiler that works with older framework versions.

Khalid Abuhakmeh
08/14/2013 02:26 PM by
Khalid Abuhakmeh

Would the shift to .NET 4.5 mean that the client's application also has to be written in .NET 4.5? If so then this could be an issue. If not, then go nuts and upgrade it.

Ian Nelson
08/14/2013 02:43 PM by
Ian Nelson

I think it's reasonable to expect developer workstations to have .NET 4.5 installed now.

Fitzchak Yitzchaki
08/14/2013 02:43 PM by
Fitzchak Yitzchaki

No, the appender has support for even .NET 3.5

Jon Sagara
08/14/2013 04:50 PM by
Jon Sagara

Requiring .NET 4.5 is okay by me.

Matthew Wills
08/14/2013 10:01 PM by
Matthew Wills

I think .NET 4.5 support in 2014 would be reasonable. Before that would be problematic for some corporate environments.

Pure Krome
08/15/2013 03:13 AM by
Pure Krome

Perfectly fine.

.NET 4.5 all the codes!

do it!

Tudor
08/19/2013 10:12 AM by
Tudor

The only possible issue is that, .NET Framework 4.5 being an in-place upgrade of 4.0 (replaces 4.0), all projects using 4.0 in that machine must be upgraded too - usually this works fine, but some components are not compatible with .NET 4.5, like Microsoft Moles.. (Microsoft abandoned Moles some time ago)

Brian Sayatovic
11/04/2013 06:01 PM by
Brian Sayatovic

.NET 4.5 is fine for me to run NHProf, but what about the assembly I have to drop in my app running on 4.0 or older? You're saying just the UI, so the assembly I embed in my app would still be less-than 4.5?

Fitzchak Yitzchaki
11/05/2013 12:55 PM by
Fitzchak Yitzchaki

@Brian, yes, the appender assembly supports .NET 4.0 and even .NET 3.5.

Dannielle Hawes
11/21/2013 10:04 PM by
Dannielle Hawes

It's reasonable to expect developer workstations to have .NET 4.5 installed

Comments have been closed on this topic.